How to fix audio issues and crashes on a Gigabyte motherboard

By on Aug 20, 2012 in Blog Posts, Hardware, Software | 3 comments

Share On GoogleShare On FacebookShare On Twitter

I’ve had problems with my Gigabyte GA-990FXA-UD5 motherboard every since I built my custom system a year ago. It wasn’t to the point where I couldn’t use it – so I didn’t have to take drastic steps – it was just annoying and would crash once every few days.

The blue screen errors were generic and generally pointed towards faulty memory. Since the memory was brand new, that seemed unlikely. I tested each stick thoroughly with Memtest86+ and found no issues. I tried different RAM slot combinations to no avail. I tested different combinations of RAM timings and clock speeds without any luck. Even Auto settings didn’t work.

After weeks of useless back and forth with Gigabyte technical support, they mentioned that the memory controller is integrated into the CPU and perhaps that could be the cause of the issue. This didn’t feel right to me, but since AMD had just released their new FX-6100 processor I decided that investing in it might give me a speed boost and solve my problem at the same time. So I replaced my Phenom II X6 1090T with the FX-6100, but did that solve the problem?


At this point I was frustrated. Gigabyte had long since given up and suggested I request an RMA for a replacement motherboard. I just didn’t feel that this would solve anything, and I could be without a working computer for weeks waiting on the replacement. There was never an indication in testing that the motherboard was faulty so I decided to simply deal with the BSODs for a while longer and hope that I could eventually resolve the issue on my own.

After some tinkering and more blue screens, I came to the conclusion that Skype was causing my crashes. This seemed plausible since I almost always left Skype running in the background. Close Skype; no crashes. Leave Skype running; crashes once a day. For a while I just used Skype when I needed it and this minimized my crashes, but that wasn’t a good solution and eventually it started to crash more often when I ran Skype.

All of this went down at the same time as another issue was occurring. For quite some time I’d been hearing popping or crackling noises in my Logitech G930 headset. The problem was subtle, but annoying. It occurred no mater what type of audio I was listening to, and it didn’t matter what volume or other settings I used. Thinking there may be something I could try to fix it that I hadn’t found via Google, I contacted Logitech support. They were somewhat more helpful than Gigabyte but in the end just suggested an RMA as well. I knew the headset wasn’t at fault because I had tested it with another computer and it worked properly, so once again I as on my own.

I decided to test my motherboard’s on-board audio to see if there were any issues with that, if only to have something to fall back on in case I had to send my headset off to be replaced. I uninstalled my G930 software and disconnected it and installed all of the latest software and drivers for my on-board audio. I immediately noticed background noise and popping, even when there was no audio playing, so I knew it wan’t just just my G930.

I opened a new ticket with Gigabyte hoping for some insight into the issue. The ticket was created on July 16th and I didn’t hear back from Gigabyte until nearly a month later on August 13th. They said to be sure that nothing was overclocked (it wasn’t) and to “…turn off any background applications running such as easy tune 6 to test the results.”

Finally, something to actually try. Easy Tune 6 (ET6) was one of the first applications I installed and had always been running. I probably disabled it for some of my early crash testing but that would have been a long time and many software updates ago.

After I uninstalled ET6 and restarted the computer, the audio popping was gone. The crashes stopped. My computer has been 100% reliable ever since.

It’s amazing to me that a program built to make managing your motherboard easier could cause so much heartache. I didn’t even use ET6 except to verify clock settings in Windows, which can be done just as easily with CPU-Z. What a craptastic piece of software.

For reference, here are some of the STOP errors I got along the way: